贴吧助手web版

 找回密码
 立即注册
搜索
查看: 1948|回复: 7

20170725百度账号注册机易语言源码

[复制链接]
     紫钻仅向指定用户开放  
  • TA的每日心情
    得意
    4 小时前
  • 签到天数: 682 天

    [LV.9]以坛为家II

    585

    主题

    1057

    帖子

    1191

    积分

    管理员

    Rank: 15Rank: 15Rank: 15Rank: 15

    金币
    3035

    接口达人工具作者土豪之星

    发表于 2017-7-25 11:42:20 | 显示全部楼层 |阅读模式
    143804u70q0i7qxrrsti7q.jpg
    部分代码如下

    .版本 2
    .支持库 spec
    .支持库 iext

    arr = 分割文本 (组合框2.内容, “:”, )
    项目id = arr [2]
    .循环判断首 ()
        pn = Getphone (项目id)
        调试输出 (pn, “aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa”)
        .如果真 (取文本长度 (pn) = 11)
            GID = JS调试 (#GID, “guideRandom”, “”)
            url = “https://wappass.baidu.com/wp/api ... l=tb&mobilenum=” + pn + “&gid=” + GID + “&tt=” + 时间_取现行时间戳 () + “&countrycode=”
            response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 0, , cookie, , , , , , , , , , )), 真)
            调试输出 (response)
            .如果真 (寻找文本 (response, “该手机已注册,可以通过密码或短信快捷登”, , 真) ≠ -1)
                addblack (pn, 项目id)
                print (#红色, pn + “,不可用”)
            .如果真结束

        .如果真结束

    .循环判断尾 (寻找文本 (response, “该手机已注册,可以通过密码或短信快捷登”, , 真) ≠ -1)
    cookie = cookie + “; Hm_lvt_294dbbdeb1fabbed8433533a3564560e=” + 时间_到时间戳 (, 真) + “; Hm_lpvt_294dbbdeb1fabbed8433533a3564560e=” + 时间_到时间戳 (, 真)
    url = “https://wappass.baidu.com/wp/api/reg/sms?tt=” + 时间_取现行时间戳 ()
    data = “mobilenum=” + pn + “&countrycode=&gid=” + GID + “&vcodesign=&vcodestr=&dialogVerifyCode=&tpl=tb&subpro=”
    response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 1, data, cookie, , , , , , , , , , )), 真)
    调试输出 (response)
    .如果真 (寻找文本 (response, “命中验证码”, , 假) ≠ -1)
        xk.进入 ()
        sy = 超级列表框1.插入表项 (, , , , , )
        xk.退出 ()
        超级列表框1.置标题 (sy, 0, 到文本 (sy + 1))
        超级列表框1.置标题 (sy, 1, pn)
        print (#绿色, pn + “,开始注册”)
        json.解析 (response)
        json.解析 (json.取属性对象 (“data”))
        vcodestr = json.取通用属性 (“vcodestr”)
        vcodesign = json.取通用属性 (“vcodesign”)
        .循环判断首 ()
            url = “https://wappass.baidu.com/cgi-bin/genimage?” + vcodestr + “&v=” + 时间_取现行时间戳 ()
            验证码图片字节集 = 网页_访问_对象 (url, 0, , cookie, , , , , , , , , , )
            验证码 = 图片识别 (验证码图片字节集)
            url = “https://wappass.baidu.com/wp/api/reg/sms?tt=” + 时间_取现行时间戳 ()
            data = “mobilenum=” + pn + “&countrycode=&gid=” + GID + “&vcodesign=” + vcodesign + “&vcodestr=” + vcodestr + “&dialogVerifyCode=” + 验证码 + “&tpl=tb&subpro=”
            response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 1, data, cookie, , , , , , , , , , )), 真)
            调试输出 (response)
            .如果真 (寻找文本 (response, “验证码有误”, , 真) ≠ -1)
                print (#红色, “验证码识别有误”)
            .如果真结束

        .循环判断尾 (寻找文本 (response, “验证码有误”, , 真) ≠ -1)
        json.解析 (response)
        json.解析 (json.取属性对象 (“data”))
        tempid = json.取通用属性 (“tempid”)
        url = “https://wappass.baidu.com/passpo ... ode&checkPhone=” + pn + “&countrycode=&tempid=” + tempid
        response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 0, , cookie, , , , , , , , , , )), 真)
        调试输出 (response)
        uid = 文本_取出中间文本 (response, “name=” + #引号 + “uid” + #引号 + “ value=” + #引号, #引号)
        bdcm = 文本_取出中间文本 (response, “name=” + #引号 + “bdcm” + #引号 + “ value=” + #引号, #引号)
        jc = 1
        .循环判断首 ()
            .如果真 (jc > 到整数 (编辑框1.内容))
                跳出循环 ()
            .如果真结束
            str = getCode (pn, arr [2])
            调试输出 (str)
            延迟 (3000)
            短信验证码 = 文本区分_只取数字 (str)
            jc = jc + 1
        .循环判断尾 (寻找文本 (str, “百度”, , 假) = -1)
        .如果 (取文本长度 (短信验证码) = 6)
            GID = JS调试 (#GID, “  guideRandom ”, “”)
            url = “https://wappass.baidu.com/wp/api/reg/phone?tt=” + 时间_取现行时间戳 ()
            data = “smsvc=” + 短信验证码 + “&action=reg&u=https%253A%252F%252Ftieba.baidu.com%252F%253Fpage%253Ddiscovery%2526uid%253D” + uid + “&tpl=tb&tn=bdIndex&pu=&ssid=&from=&bd_page_type=&uid=” + uid + “&type=&regtype=1&subpro=&adapter=0&skin=default_v2&regist_mode=&login_share_strategy=&client=&clientfrom=&connect=&bindToSmsLogin=&bdcm=” + bdcm + “&tempid=” + tempid + “&agreement=1&dialogVerifyCode=&vcodesign=&vcodestr=&countrycode=&logRegType=wap_regTouch&mobilenum=” + pn + “&gid=” + GID + “&nopsw=1&forcesetpwd=”
            response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 1, data, cookie, , , , , , , , , , )), 真)
            调试输出 (response)
            json.解析 (response)
            gotoUrl = json.取通用属性 (“data.gotoUrl”)
            authsid = 文本_取出中间文本 (gotoUrl, “authsid=”, “&”)
            bdstoken = 文本_取出中间文本 (gotoUrl + “!”, “bdstoken=”, “!”)
            .如果 (authsid ≠ “” 且 bdstoken ≠ “”)
                response = 编码_URL解码 (到文本 (网页_访问_对象 (gotoUrl, 0, , cookie, , , , , , , , , , )), 真)
                调试输出 (response)
                GID = JS调试 (#GID, “  guideRandom ”, “”)
                .循环判断首 ()
                    .如果 (选择框4.选中 = 真)
                        账号 = 文本_取随机汉字 (取随机数 (到整数 (编辑框11.内容), 到整数 (编辑框12.内容)))
                    .否则
                        账号 = 文本_取随机字母 (到整数 (编辑框4.内容), ) + 文本_取随机数字 (到整数 (编辑框5.内容), )
                    .如果结束
                    密码 = 文本_取随机字母 (到整数 (编辑框8.内容), ) + 文本_取随机数字 (到整数 (编辑框9.内容), )
                    url = “https://wappass.baidu.com/wp/api ... pl=tb&username=” + 编码_URL编码 (账号, 真, 真) + “&gid=” + GID + “&tt=” + 时间_取现行时间戳 ()
                    response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 0, , cookie, , , , , , , , , , )), 真)
                    调试输出 (response)
                    json.解析 (response)
                    response = json.取通用属性 (“errInfo.no”)
                .循环判断尾 (response ≠ “0”)
                超级列表框1.置标题 (sy, 2, 账号)
                超级列表框1.置标题 (sy, 3, 密码)
                url = “https://wappass.baidu.com/v3/getpass/api/showsetpwdusername/?v=” + 时间_取现行时间戳 ()
                pwd = JS调试 (#password_1, “getpwd”, “'” + 密码 + “'”)
                data = “username=” + 编码_URL编码 (账号, 真, 真) + “&password=” + pwd + “&action=&u=https%3A%2F%2Ftieba.baidu.com%2F%3Fpage%3Ddiscovery%26uid%3D” + uid + “&tpl=tb&tn=&pu=&ssid=&from=&bd_page_type=&uid=&type=&regtype=&subpro=&adapter=&skin=&regist_mode=&login_share_strategy=&client=&clientfrom=&connect=&bindToSmsLogin=&authsid=” + authsid + “&bdstoken=” + bdstoken
                response = 编码_URL解码 (到文本 (网页_访问_对象 (url, 1, data, cookie, , , , , , , , , , )), 真)
                调试输出 (response)
                json.解析 (response)
                data = json.取通用属性 (“errInfo.msg”)
                response = json.取通用属性 (“errInfo.no”)
                .如果 (response = “0”)
                    xk.进入 ()
                    注册成功数 = 注册成功数 + 1
                    xk.退出 ()
                    超级列表框1.置标题 (sy, 6, “注册成功”)
                    bduss = 网页_取单条Cookie (cookie, “BDUSS”, 假)
                    调试输出 (cookie)
                    print (#绿色, pn + “,注册成功”)
                    .如果 (选择框2.选中)
                        .如果 (Bind_mailbox (pn, 邮箱, 邮箱密码, cookie, 项目id) = 真)
                            print (#黄色, pn + “>>>>绑定邮箱成功”)
                            超级列表框1.置标题 (sy, 4, 邮箱)
                            超级列表框1.置标题 (sy, 5, 邮箱密码)
                            超级列表框1.置标题 (sy, 6, “绑定邮箱成功”)
                            xk.进入 ()
                            .循环判断首 ()
                                bool = 写到文件 (取运行目录 () + “\百度绑邮箱成功-接口4.txt”, 读入文件 (取运行目录 () + “\百度绑邮箱成功-接口4.txt”) + 到字节集 (pn + “----” + 密码 + “----” + 邮箱 + “----” + 邮箱密码 + “----” + bduss + #换行符))
                            .循环判断尾 (bool = 假)
                            xk.退出 ()
                            .如果真 (选择框3.选中 = 真)
                                .如果 (Binding_phone (pn, cookie))
                                    超级列表框1.置标题 (sy, 6, “解绑手机成功”)
                                    print (#黄色, pn + “>>>>解绑成功”)
                                .否则
                                    超级列表框1.置标题 (sy, 6, “解绑手机失败”)
                                    print (#黄色, pn + “>>>>解绑失败”)
                                .如果结束

                            .如果真结束




                        .否则
                            xk.进入 ()
                            超级列表框1.置标题 (sy, 6, “绑定邮箱失败”)
                            .循环判断首 ()
                                bool = 写到文件 (取运行目录 () + “\百度注册成功-接口4.txt”, 读入文件 (取运行目录 () + “\百度注册成功-接口4.txt”) + 到字节集 (pn + “----” + 密码 + “----” + bduss + #换行符))
                            .循环判断尾 (bool = 假)
                            xk.退出 ()
                            print (#黄色, pn + “>>>>绑定邮箱失败”)

                        .如果结束


                        xk.进入 ()
                        bhjc = bhjc + 1
                        .如果真 (bhjc > 3 且 拨号boll = 假)
                            拨号boll = 真
                            xc.创建 (&_Adsl拨号)
                        .如果真结束
                        xk.退出 ()
                        .判断循环首 (拨号boll)
                            延迟 (500)
                        .判断循环尾 ()



                    .否则
                        xk.进入 ()
                        .循环判断首 ()
                            bool = 写到文件 (取运行目录 () + “\百度注册成功-接口4.txt”, 读入文件 (取运行目录 () + “\百度注册成功-接口4.txt”) + 到字节集 (pn + “----” + 密码 + “----” + bduss + #换行符))
                        .循环判断尾 (bool = 假)
                        xk.退出 ()
                    .如果结束









                .否则
                    xk.进入 ()
                    注册失败数 = 注册失败数 + 1
                    超级列表框1.置标题 (sy, 6, data)
                    xk.退出 ()
                .如果结束

            .否则
                超级列表框1.置标题 (sy, 6, response)
                xk.进入 ()
                注册失败数 = 注册失败数 + 1
                xk.退出 ()
            .如果结束

        .否则
            超级列表框1.置标题 (sy, 6, “短信超时”)

        .如果结束





    .如果真结束


    延迟 (到整数 (延迟.内容))




    成品源码:
    游客,如果您要查看本帖隐藏内容请回复





    上一篇:百度贴吧类目提取帐号小工具,提取精准用户,针对性较强V1.1
    下一篇:2017年7月26日签到记录贴
    喵星人贴吧助手你值得拥有
    回复

    使用道具 举报

            
  • TA的每日心情
    开心
    2017-7-27 17:30
  • 签到天数: 1 天

    [LV.1]初来乍到

    0

    主题

    3

    帖子

    3

    积分

    按个爪印

    Rank: 1

    金币
    9
    发表于 2017-7-27 17:56:13 | 显示全部楼层
    确实是难得好帖啊,顶先
    回复 支持 反对

    使用道具 举报

            
  • TA的每日心情
    生气
    2018-9-18 19:07
  • 签到天数: 28 天

    [LV.4]偶尔看看III

    6

    主题

    50

    帖子

    32

    积分

    按个爪印

    Rank: 1

    金币
    76
    发表于 2017-8-29 16:32:53 | 显示全部楼层
    dd回的人少,我来小顶一下
    该会员没有填写今日想说内容.
    回复 支持 反对

    使用道具 举报

            
  • TA的每日心情
    吃惊
    2018-9-30 21:51
  • 签到天数: 25 天

    [LV.4]偶尔看看III

    1

    主题

    34

    帖子

    19

    积分

    按个爪印

    Rank: 1

    金币
    64
    发表于 2017-9-2 14:51:15 | 显示全部楼层
    确实是难得好帖啊,顶先
    该会员没有填写今日想说内容.
    回复 支持 反对

    使用道具 举报

            
  • TA的每日心情
    得意
    2018-3-30 01:17
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    1

    主题

    6

    帖子

    4

    积分

    按个爪印

    Rank: 1

    金币
    15
    发表于 2017-9-24 19:38:59 | 显示全部楼层
    jiushilaikankan确实是难得好帖啊,顶先
    喵星人贴吧助手你值得拥有
    回复 支持 反对

    使用道具 举报

            
  • TA的每日心情
    生气
    2018-3-31 09:06
  • 签到天数: 8 天

    [LV.3]偶尔看看II

    0

    主题

    20

    帖子

    10

    积分

    按个爪印

    Rank: 1

    金币
    33
    发表于 2018-1-31 13:01:10 | 显示全部楼层
    啥也不说了,感谢楼主分享哇!
    喵星人贴吧助手你值得拥有
    回复 支持 反对

    使用道具 举报

            
  • TA的每日心情
    开心
    2018-4-27 17:11
  • 签到天数: 7 天

    [LV.3]偶尔看看II

    2

    主题

    14

    帖子

    9

    积分

    按个爪印

    Rank: 1

    金币
    28
    发表于 2018-1-31 19:46:15 | 显示全部楼层
    啥也不说了,感谢楼主分享哇!
    喵星人贴吧助手你值得拥有
    回复 支持 反对

    使用道具 举报

            
  • TA的每日心情
    吃惊
    2018-8-21 08:19
  • 签到天数: 73 天

    [LV.6]常住居民II

    26

    主题

    119

    帖子

    87

    积分

    伸爪卖嗲

    Rank: 4

    金币
    273
    发表于 2018-6-26 10:25:47 | 显示全部楼层
    感谢楼主 不错不错
    该会员没有填写今日想说内容.
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    网站地图|Archiver|手机版|小黑屋|贴吧助手web版

    Copyright © 2016-2020 TieBaZSTool by TieBaZSAll Rights Reserved.

    快速回复 返回顶部 返回列表